<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
			<link rel="shortcut icon" href="http://devconnected.com/wp-content/uploads/2019/04/1_20ejjBnUDvsHi2SGNwpEwQ.png" type="image/x-icon" />
		<link rel="apple-touch-icon" sizes="180x180" href="http://devconnected.com/wp-content/uploads/2019/04/1_20ejjBnUDvsHi2SGNwpEwQ.png">
		<link rel="alternate" type="application/rss+xml" title="devconnected RSS Feed" href="http://devconnected.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="devconnected Atom Feed" href="http://devconnected.com/feed/atom/" />
	<link rel="pingback" href="http://devconnected.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="http://devconnected.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
	<title>The Definitive Guide to Centralized Logging with Syslog on Linux</title>

<!-- This site is optimized with the Yoast SEO plugin v11.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Step by step guide on how to setup a complete centralized logging architecture with syslog on Linux. Includes TLS and memory queues."/>
<link rel="canonical" href="http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The Definitive Guide to Centralized Logging with Syslog on Linux" />
<meta property="og:description" content="Step by step guide on how to setup a complete centralized logging architecture with syslog on Linux. Includes TLS and memory queues." />
<meta property="og:url" content="http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/" />
<meta property="og:site_name" content="devconnected" />
<meta property="article:tag" content="architecture" />
<meta property="article:tag" content="centralized architecture" />
<meta property="article:tag" content="logging" />
<meta property="article:tag" content="rsyslog" />
<meta property="article:tag" content="syslog" />
<meta property="article:tag" content="system administration" />
<meta property="article:section" content="Guide" />
<meta property="article:published_time" content="2019-07-28T15:32:11+00:00" />
<meta property="article:modified_time" content="2019-07-28T15:34:33+00:00" />
<meta property="og:updated_time" content="2019-07-28T15:34:33+00:00" />
<meta property="og:image" content="http://devconnected.com/wp-content/uploads/2019/07/centralized-logging.png" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Step by step guide on how to setup a complete centralized logging architecture with syslog on Linux. Includes TLS and memory queues." />
<meta name="twitter:title" content="The Definitive Guide to Centralized Logging with Syslog on Linux" />
<meta name="twitter:image" content="http://devconnected.com/wp-content/uploads/2019/07/centralized-logging.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://devconnected.com/#organization","name":"devconnected","url":"http://devconnected.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"http://devconnected.com/#logo","url":"http://devconnected.com/wp-content/uploads/2019/04/logo-1.png","width":409,"height":105,"caption":"devconnected"},"image":{"@id":"http://devconnected.com/#logo"}},{"@type":"WebSite","@id":"http://devconnected.com/#website","url":"http://devconnected.com/","name":"devconnected","publisher":{"@id":"http://devconnected.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://devconnected.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#primaryimage","url":"http://devconnected.com/wp-content/uploads/2019/07/centralized-logging.png","width":1280,"height":720},{"@type":"WebPage","@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#webpage","url":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/","inLanguage":"en-US","name":"The Definitive Guide to Centralized Logging with Syslog on Linux","isPartOf":{"@id":"http://devconnected.com/#website"},"primaryImageOfPage":{"@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#primaryimage"},"datePublished":"2019-07-28T15:32:11+00:00","dateModified":"2019-07-28T15:34:33+00:00","description":"Step by step guide on how to setup a complete centralized logging architecture with syslog on Linux. Includes TLS and memory queues."},{"@type":"Article","@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#article","isPartOf":{"@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#webpage"},"author":{"@id":"http://devconnected.com/#/schema/person/75989f9715e2ceba8f277d7b93706476"},"headline":"The Definitive Guide to Centralized Logging with Syslog on Linux","datePublished":"2019-07-28T15:32:11+00:00","dateModified":"2019-07-28T15:34:33+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#webpage"},"publisher":{"@id":"http://devconnected.com/#organization"},"image":{"@id":"http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#primaryimage"},"keywords":"architecture,centralized architecture,logging,rsyslog,syslog,system administration","articleSection":"Guide,Logging"},{"@type":["Person"],"@id":"http://devconnected.com/#/schema/person/75989f9715e2ceba8f277d7b93706476","name":"schkn","image":{"@type":"ImageObject","@id":"http://devconnected.com/#authorlogo","url":"http://0.gravatar.com/avatar/96c5601ef18e54ecc99dbb77e5da7d69?s=96&d=mm&r=g","caption":"schkn"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//devconnected.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="devconnected &raquo; Feed" href="http://devconnected.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="devconnected &raquo; Comments Feed" href="http://devconnected.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="devconnected &raquo; The Definitive Guide to Centralized Logging with Syslog on Linux Comments Feed" href="http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.7.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.7.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-125805120-3';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-125805120-3', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/devconnected.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='penci-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto+Mono%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COpen+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://devconnected.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='http://devconnected.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://devconnected.com/wp-content/uploads/hummingbird-assets/25107ea40f8e935ab1306b4f7e223afb.css' type='text/css' media='all' />
<link rel='stylesheet' id='ez-icomoon-css'  href='http://devconnected.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='http://devconnected.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=1.7' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}
</style>
<link rel='stylesheet' id='penci_style-css'  href='http://devconnected.com/wp-content/themes/soledad/style.css?ver=6.3.1' type='text/css' media='all' />
<link rel='stylesheet' id='instag-slider-css'  href='http://devconnected.com/wp-content/uploads/hummingbird-assets/13d89d7b7a4c64c7f423ec1238e7b83c.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"http:\/\/devconnected.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.7.1'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/764ea5e8831b56937701c4d60e0711db.js'></script>
<script type='text/javascript' src='http://devconnected.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://devconnected.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/8b7aaaa4861412a1723741c122194c4a.js'></script>
<link rel='https://api.w.org/' href='http://devconnected.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://devconnected.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://devconnected.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='http://devconnected.com/?p=2959' />
<link rel="alternate" type="application/json+oembed" href="http://devconnected.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdevconnected.com%2Fthe-definitive-guide-to-centralized-logging-with-syslog-on-linux%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://devconnected.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdevconnected.com%2Fthe-definitive-guide-to-centralized-logging-with-syslog-on-linux%2F&#038;format=xml" />
<script type="text/javascript">var ajaxurl = "http://devconnected.com/wp-admin/admin-ajax.php";</script>	<style type="text/css">
																													</style>
	<style type="text/css">
																											</style>
<script>var portfolioDataJs = portfolioDataJs || [];</script>		<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
		    <style type="text/css">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</style>
    <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "http:\/\/devconnected.com\/wp-content\/uploads\/2019\/04\/logo2.png"
    },
    "url": "http:\/\/devconnected.com\/",
    "name": "devconnected",
    "description": "Software Engineering Articles, Guides &amp; Tips"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "devconnected",
    "alternateName": "Software Engineering Articles, Guides &amp; Tips",
    "url": "http:\/\/devconnected.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "The Definitive Guide to Centralized Logging with Syslog on Linux",
    "description": "",
    "datePublished": "2019-07-28",
    "datemodified": "2019-07-28",
    "mainEntityOfPage": "http:\/\/devconnected.com\/the-definitive-guide-to-centralized-logging-with-syslog-on-linux\/",
    "image": {
        "@type": "ImageObject",
        "url": "http:\/\/devconnected.com\/wp-content\/uploads\/2019\/07\/centralized-logging.png",
        "width": 1280,
        "height": 720
    },
    "publisher": {
        "@type": "Organization",
        "name": "devconnected",
        "logo": {
            "@type": "ImageObject",
            "url": "http:\/\/devconnected.com\/wp-content\/uploads\/2019\/04\/logo2.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-schkn",
        "name": "schkn"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "http:\/\/devconnected.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "http:\/\/devconnected.com\/category\/guide\/",
                "name": "Guide"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "http:\/\/devconnected.com\/the-definitive-guide-to-centralized-logging-with-syslog-on-linux\/",
                "name": "The Definitive Guide to Centralized Logging with Syslog on Linux"
            }
        }
    ]
}</script>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		</head>

<body class="post-template-default single single-post postid-2959 single-format-standard penci-vernav-enable penci-vernav-poleft">
	<a class="penci-vernav-toggle" href="#"><i class="fa fa-bars"></i></a>
<div class="penci-menu-hbg penci-vernav-show penci-menu-hbg-left">
	<div class="penci-menu-hbg-inner">
						<div class="penci-hbg-header">
							<div class="penci-hbg-logo site-branding">
											<a href="http://devconnected.com/"><img class="penci-lazy" src="http://devconnected.com/wp-content/themes/soledad/images/penci-holder.png" data-src="http://devconnected.com/wp-content/uploads/2019/04/logo2.png" alt="devconnected"/></a>
									</div>
						</div>
						<div class="penci-hbg-search-box">
			<form role="search" method="get" id="searchform" class="penci-hbg-search-form" action="http://devconnected.com/">
				<div class="inner-hbg-search-form">
					<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
					<i class="fa fa-search"></i>
				</div>
			</form>
		</div>
				<div class="penci-hbg-content penci-sidebar-content style-7 pcalign-left">
						<ul id="menu-left-menu" class="menu menu-hgb-main"><li id="menu-item-1889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1889"><a href="http://devconnected.com">Home</a></li>
<li id="menu-item-2868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2868"><a href="http://devconnected.com/category/monitoring/">Monitoring</a>
<ul class="sub-menu">
	<li id="menu-item-3112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3112"><a href="http://devconnected.com/category/monitoring/grafana/">Grafana</a></li>
	<li id="menu-item-3111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3111"><a href="http://devconnected.com/category/monitoring/influxdb/">InfluxDB</a></li>
	<li id="menu-item-2873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2873"><a href="http://devconnected.com/category/monitoring/kibana/">Kibana</a></li>
	<li id="menu-item-3113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3113"><a href="http://devconnected.com/category/monitoring/prometheus/">Prometheus</a></li>
</ul>
</li>
<li id="menu-item-1891" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1891"><a href="http://devconnected.com/category/guide/">Guide</a></li>
<li id="menu-item-1893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1893"><a href="http://devconnected.com/category/devops/">DevOps</a>
<ul class="sub-menu">
	<li id="menu-item-2871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2871"><a href="http://devconnected.com/category/devops/elk-stack/">ELK stack</a></li>
</ul>
</li>
<li id="menu-item-1894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1894"><a href="http://devconnected.com/category/productivity/">Productivity</a></li>
<li id="menu-item-1890" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1890"><a href="http://devconnected.com/category/software-engineering/">Software Engineering</a></li>
<li id="menu-item-2462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2462"><a href="http://devconnected.com/about/">About</a></li>
</ul>						<div class="penci-menu-hbg-widgets2">
				<aside id="penci_popular_news_widget-1" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular Posts</span></h4>				<ul id="penci-popularwg-8109" class="side-newsfeed display-order-numbers">

					
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">1</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="http://devconnected.com/wp-content/uploads/2019/06/featured-image-1-263x175.png" href="http://devconnected.com/how-to-install-grafana-on-ubuntu-18-04/" title="How To Install Grafana on Ubuntu 18.04"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="http://devconnected.com/how-to-install-grafana-on-ubuntu-18-04/" rel="bookmark" title="How To Install Grafana on Ubuntu 18.04">
											How To Install Grafana on Ubuntu 18.04										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2019-06-30T17:58:19+00:00">June 30, 2019</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">2</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="http://devconnected.com/wp-content/uploads/2019/06/featured-1-263x175.png" href="http://devconnected.com/complete-node-exporter-mastery-with-prometheus/" title="Complete Node Exporter Mastery with Prometheus"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="http://devconnected.com/complete-node-exporter-mastery-with-prometheus/" rel="bookmark" title="Complete Node Exporter Mastery with Prometheus">
											Complete Node Exporter Mastery with Prometheus										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2019-06-22T16:12:04+00:00">June 22, 2019</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">3</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="http://devconnected.com/wp-content/uploads/2019/07/final-dashboard-1-263x175.png" href="http://devconnected.com/monitoring-linux-logs-with-kibana-and-rsyslog/" title="Monitoring Linux Logs with Kibana and Rsyslog"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="http://devconnected.com/monitoring-linux-logs-with-kibana-and-rsyslog/" rel="bookmark" title="Monitoring Linux Logs with Kibana and Rsyslog">
											Monitoring Linux Logs with Kibana and Rsyslog										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2019-07-16T18:06:41+00:00">July 16, 2019</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">4</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="http://devconnected.com/wp-content/uploads/2019/07/featured-263x175.png" href="http://devconnected.com/how-to-install-influxdb-on-ubuntu-debian-in-2019/" title="How To Install InfluxDB 1.7 and 2.0 on Linux in 2019"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="http://devconnected.com/how-to-install-influxdb-on-ubuntu-debian-in-2019/" rel="bookmark" title="How To Install InfluxDB 1.7 and 2.0 on Linux in 2019">
											How To Install InfluxDB 1.7 and 2.0 on Linux in 2019										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2019-07-06T10:08:21+00:00">July 6, 2019</time></span>
																	</div>
							</div>
						</li>

						
						<li class="penci-feed">
															<span class="order-border-number">
								<span class="number-post">5</span>
							</span>
														<div class="side-item">
																	<div class="side-image">
																															<a class="penci-image-holder penci-lazy small-fix-size" rel="bookmark" data-src="http://devconnected.com/wp-content/uploads/2019/06/Copie-de-Copie-de-DevOps-3-263x175.png" href="http://devconnected.com/how-to-create-a-grafana-dashboard-ui-api-methods/" title="How To Create a Grafana Dashboard? (UI + API methods)"></a>
										
																			</div>
																<div class="side-item-text">
									<h4 class="side-title-post">
										<a href="http://devconnected.com/how-to-create-a-grafana-dashboard-ui-api-methods/" rel="bookmark" title="How To Create a Grafana Dashboard? (UI + API methods)">
											How To Create a Grafana Dashboard? (UI + API methods)										</a>
									</h4>
																			<span class="side-item-meta"><time class="entry-date published" datetime="2019-06-18T21:18:17+00:00">June 18, 2019</time></span>
																	</div>
							</div>
						</li>

						
				</ul>

			</aside>			</div>
					</div>
		<div class="penci-hbg-footer">
			<div class="penci_menu_hbg_ftext">Copyright © 2019 Antoine Solnichkin for devconnected. All rights reserved</div>												<div class="header-social sidebar-nav-social penci-hbg-social-style-4 hgb-social-style-5 penci-social-colored">
						<div class="inner-header-social">
				<a href="https://twitter.com/devconnectedcom" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a>
							<a href="https://www.linkedin.com/in/antoine-solnichkin-2ba22a54/" rel="nofollow" target="_blank"><i class="fa fa-linkedin"></i></a>
								<a href="mailto:solnichkin.antoine@gmail.com"><i class="fa fa-envelope-o"></i></a>
										<a href="http://www.github.com/SCHKN" rel="nofollow" target="_blank"><i class="fa fa-github"></i></a>
															</div>					</div>
							
		</div>
	</div>
</div>
<!-- .wrapper-boxed -->
<div class="wrapper-boxed header-style-header-1">

	<!-- Top Instagram -->
	
	<!-- Top Bar -->
			<div class="penci-top-bar topbar-fullwidth">
	<div class="container">
		<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
										<span class="headline-title">Trending</span>
										<div class="penci-topbar-social">
					<div class="inner-header-social">
				<a href="https://twitter.com/devconnectedcom" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a>
							<a href="https://www.linkedin.com/in/antoine-solnichkin-2ba22a54/" rel="nofollow" target="_blank"><i class="fa fa-linkedin"></i></a>
								<a href="mailto:solnichkin.antoine@gmail.com"><i class="fa fa-envelope-o"></i></a>
										<a href="http://www.github.com/SCHKN" rel="nofollow" target="_blank"><i class="fa fa-github"></i></a>
															</div>				</div>
											<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/">The Definitive Guide to Centralized Logging with Syslog...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/the-10-best-software-engineering-books-in-2019/">The 10 Best Software Engineering Books in 2019</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/monitoring-linux-logs-with-kibana-and-rsyslog/">Monitoring Linux Logs with Kibana and Rsyslog</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/how-to-install-an-elasticsearch-cluster-on-ubuntu-18-04/">How To Install an Elasticsearch Cluster on Ubuntu...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/mongodb-monitoring-with-grafana-prometheus/">MongoDB Monitoring with Grafana &#038; Prometheus</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/complete-node-exporter-mastery-with-prometheus/">Complete Node Exporter Mastery with Prometheus</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/influxdays-london-2019-recap/">InfluxDays London 2019 Recap</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/monitoring-linux-processes-using-prometheus-and-grafana/">Monitoring Linux Processes using Prometheus and Grafana</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/the-definitive-guide-to-influxdb-in-2019/">The Definitive Guide To InfluxDB In 2019</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/4-best-time-series-databases-to-watch-in-2019/">4 Best Time Series Databases To Watch in...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/how-to-install-logstash-on-ubuntu-18-04-and-debian-9/">How To Install Logstash on Ubuntu 18.04 and...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/how-to-install-influxdb-on-ubuntu-debian-in-2019/">How To Install InfluxDB 1.7 and 2.0 on...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/how-to-install-grafana-on-ubuntu-18-04/">How To Install Grafana on Ubuntu 18.04</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://devconnected.com/how-to-create-a-grafana-dashboard-ui-api-methods/">How To Create a Grafana Dashboard? (UI +...</a>
							</div>
											</div>
									</div>
	</div>
</div>		
	
	<header id="header" class="header-header-1 has-bottom-line penci-vernav-hide-innerhead" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><!-- #header -->
		
			</header>
	<!-- end #header -->
		
			
			<div class="container penci-breadcrumb single-breadcrumb">
			<span><a class="crumb" href="http://devconnected.com/">Home</a></span><i class="fa fa-angle-right"></i>
			<span><a class="crumb" href="http://devconnected.com/category/guide/">Guide</a></span><i class="fa fa-angle-right"></i>			<span>The Definitive Guide to Centralized Logging with Syslog on Linux</span>
		</div>
			

<div class="container container-single penci_sidebar right-sidebar penci-enable-lightbox">
	<div id="main" class="penci-main-sticky-sidebar">
		<div class="theiaStickySidebar">
											<article id="post-2959" class="post type-post status-publish hentry">

	
	
	<div class="header-standard header-classic single-header">
					<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="http://devconnected.com/category/guide/"  rel="category tag">Guide</a><a class="penci-cat-name" href="http://devconnected.com/category/linux-administration/logging/"  rel="category tag">Logging</a></span></div>
		
		<h1 class="post-title single-post-title entry-title">The Definitive Guide to Centralized Logging with Syslog on Linux</h1>
				<div class="penci-hide-tagupdated">
			<span class="author-italic author vcard">by <a class="url fn n" href="http://devconnected.com/author/schkn/">schkn</a></span>
			<time class="entry-date published" datetime="2019-07-28T15:32:11+00:00">July 28, 2019</time>		</div>
							<div class="post-box-meta-single">
									<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="http://devconnected.com/author/schkn/">schkn</a></span></span>
													<span><time class="entry-date published" datetime="2019-07-28T15:32:11+00:00">July 28, 2019</time></span>
											</div>
			</div>

	
	
	
									<div class="post-image">
					<a href="http://devconnected.com/wp-content/uploads/2019/07/centralized-logging.png" data-rel="penci-gallery-image-content">													<img class="attachment-penci-full-thumb size-penci-full-thumb penci-lazy wp-post-image" src="http://devconnected.com/wp-content/themes/soledad/images/penci2-holder.png" alt="The Definitive Guide to Centralized Logging with Syslog on Linux" title="centralized logging" data-src="http://devconnected.com/wp-content/uploads/2019/07/centralized-logging-1170x658.png">
												</a>				</div>
					
	
	
	
	
	<div class="post-entry blockquote-style-2">
		<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
			
<p><em>This article details all the steps needed to build a centralized logging architecture on Linux systems.</em></p>



<p>If you are a <strong>Linux system administrator</strong>, you probably spend a lot of time <strong>browsing your log files</strong> in order to find relevant information about past events.</p>



<p>Most of the time, you are not working with a single machine, but with <strong>many different Linux machines</strong>, each having its own local log storage.</p>



<p>Now if you were to browse logs for many different machines, you would have to individually connect to every single one of them, locate logs and try to find the information that you are looking for.</p>



<p>This is of course in the case where you can physically access the machine, presupposing that the machine is up and that you are not denied the access to it.</p>



<blockquote class="wp-block-quote"><p>But what if we could have a centralized way to store our logs, on a remote machine? </p></blockquote>



<p>What if we could access log files from <strong>a single point? </strong></p>



<p>Wouldn&#8217;t it be <strong>easier</strong> and more<strong> reliable?</strong> </p>



<p>In this definitive guide, we are going to build a <strong>centralized logging system using Syslog on Linux systems</strong>.</p>



<p>We will go through every single step that you need to put in place to build a reliable, secure, and functional centralized logging system.</p>



<blockquote class="wp-block-quote"><p>Ready?</p></blockquote>



<div id="ez-toc-container" class="counter-hierarchy counter-decimal ez-toc-grey">
<div class="ez-toc-title-container">
<p class="ez-toc-title">Table of Contents</p>
<span class="ez-toc-title-toggle"><a class="ez-toc-pull-right ez-toc-btn ez-toc-btn-xs ez-toc-btn-default ez-toc-toggle"><i class="ez-toc-glyphicon ez-toc-icon-toggle"></i></a></span></div>
<nav><ul class="ez-toc-list"><li><a href="#I_What_You_Will_Learn" title="I &#8211; What You Will Learn?">I &#8211; What You Will Learn?</a></li><li><a href="#II_How_does_Linux_logging_works_on_a_single_instance" title="II &#8211; How does Linux logging works on a single instance?">II &#8211; How does Linux logging works on a single instance?</a><ul><li><a href="#a_General_concepts_of_Linux_logging" title="a &#8211; General concepts of Linux logging">a &#8211; General concepts of Linux logging</a></li><li><a href="#b_Where_are_logs_stored_on_a_Linux_filesystem" title="b &#8211; Where are logs stored on a Linux filesystem?">b &#8211; Where are logs stored on a Linux filesystem?</a></li></ul></li><li><a href="#III_Designing_a_centralized_logging_architecture_on_Linux" title="III &#8211; Designing a centralized logging architecture on Linux">III &#8211; Designing a centralized logging architecture on Linux</a></li><li><a href="#IV_Configure_rsyslog_to_forward_logs_to_a_centralized_server" title="IV &#8211; Configure rsyslog to forward logs to a centralized server">IV &#8211; Configure rsyslog to forward logs to a centralized server</a><ul><li><a href="#a_Prerequisites" title="a &#8211; Prerequisites">a &#8211; Prerequisites</a></li><li><a href="#a_Configure_your_rsyslog_server" title="a &#8211; Configure your rsyslog server">a &#8211; Configure your rsyslog server</a></li><li><a href="#b_Configure_your_rsyslog_client" title="b &#8211; Configure your rsyslog client">b &#8211; Configure your rsyslog client</a></li></ul></li><li><a href="#V_Encrypting_rsyslog_messages_with_TLS" title=" V &#8211; Encrypting rsyslog messages with TLS"> V &#8211; Encrypting rsyslog messages with TLS</a><ul><li><a href="#a_Configuring_your_certificate_authority" title="a &#8211; Configuring your certificate authority">a &#8211; Configuring your certificate authority</a></li><li><a href="#b_Generating_privatepublic_keys_for_the_server" title="b &#8211; Generating private/public keys for the server">b &#8211; Generating private/public keys for the server</a></li><li><a href="#c_Generate_privatepublic_keys_for_the_client" title="c &#8211; Generate private/public keys for the client">c &#8211; Generate private/public keys for the client</a></li><li><a href="#d_Send_generated_keys_to_your_hosts" title="d &#8211; Send generated keys to your hosts">d &#8211; Send generated keys to your hosts</a></li><li><a href="#e_Configure_your_rsyslog_server" title="e &#8211; Configure your rsyslog server">e &#8211; Configure your rsyslog server</a></li><li><a href="#f_Configure_your_rsyslog_client" title="f &#8211; Configure your rsyslog client">f &#8211; Configure your rsyslog client</a></li></ul></li><li><a href="#VI_Sending_log_messages_reliably_with_action_queues" title="VI &#8211; Sending log messages reliably with action queues">VI &#8211; Sending log messages reliably with action queues</a><ul><li><a href="#a_Designing_message_reliability" title="a &#8211; Designing message reliability">a &#8211; Designing message reliability</a></li><li><a href="#b_Demonstrating_message_reliability" title="b &#8211; Demonstrating message reliability">b &#8211; Demonstrating message reliability</a></li></ul></li><li><a href="#Common_Errors" title="Common Errors">Common Errors</a></li><li><a href="#Bonus_A_word_on_back-pressure_protocols" title="Bonus : A word on back-pressure protocols">Bonus : A word on back-pressure protocols</a><ul><li><a href="#a_Architectural_improvements" title="a &#8211; Architectural improvements">a &#8211; Architectural improvements</a></li><li><a href="#b_Push_vs_Pull_logging_systems" title="b &#8211; Push vs Pull logging systems">b &#8211; Push vs Pull logging systems</a></li></ul></li><li><a href="#Conclusion" title="Conclusion">Conclusion</a></li></ul></nav></div>
<h2><span class="ez-toc-section" id="I_What_You_Will_Learn">I &#8211; What You Will Learn?</span></h2>



<p>As always, let&#8217;s start by having a look at everything that you are going to learn if you follow the tutorial until the end.</p>



<p>With this tutorial, you are going to learn:</p>



<ul><li>How <strong>Linux logging works</strong> on a single instance, where to look after logs;</li><li>What a centralized logging architecture looks like : <strong>advantages</strong> and <strong>drawbacks</strong> of using it;</li><li>How to setup <strong>rsyslog forwarding</strong> from a client to a centralized server;</li><li>How to secure log forwarding using <strong>the TLS protocol</strong>;</li><li>How to send logs using reliable mechanisms such as <strong>action queues</strong>.</li></ul>



<p>That&#8217;s a long program, but feel free to skip some sections if you are already comfortable with some of the concepts explained in this article.</p>



<h2><span class="ez-toc-section" id="II_How_does_Linux_logging_works_on_a_single_instance">II &#8211; How does Linux logging works on a single instance?</span></h2>



<p>Let&#8217;s start with a bit of history about Linux logging.</p>



<h3><span class="ez-toc-section" id="a_General_concepts_of_Linux_logging">a &#8211; General concepts of Linux logging</span></h3>



<p>Before jumping into building our centralized logging architecture, there are some concepts about logging on a single instance that are mandatory to understand more complex concepts.</p>



<p>By default, your Linux operating system records logs about many events that are happening on your machine. </p>



<p>Linux uses the <strong>syslog protocol</strong> which defines a standard for every aspect of logging on an operating system (not only Linux, but also Windows) : defining what a message looks like, describing<strong> severity levels</strong> on messages, as well as listing the ports that syslog will be using.</p>



<p>Syslog can be used as <strong>a server</strong> (hosting the logs) or as <strong>a client</strong> (forwarding the logs to a remote server). </p>



<p>As a consequence, the syslog protocol also defines how log transmission should be done, both in a reliable and in a secure way.</p>



<p>If you are using a modern Linux distribution (like a Ubuntu machine, a CentOS or a RHEL one), the default syslog server used is <strong>rsyslog</strong>. </p>



<div class="wp-block-image"><figure class="aligncenter is-resized"><img  alt="rsyslog presentation card"  width="643" height="341" data-srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card.png 643w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card-300x159.png 300w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card-585x310.png 585w" sizes="(max-width: 643px) 100vw, 643px" data-src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card.png" data-sizes="auto" class="wp-image-3048 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card.png" alt="rsyslog presentation card" class="wp-image-3048" width="643" height="341" srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card.png 643w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card-300x159.png 300w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-card-585x310.png 585w" sizes="(max-width: 643px) 100vw, 643px" /></noscript></figure></div>



<p>Rsyslog comes as an evolution of syslog, providing capabilities such as <strong>configurable modules</strong> that can be bound to a wide variety of targets (forwarding Apache logs to a remote server for example).</p>



<p>Rsyslog also provides <strong>native filtering</strong> as well as templating to format data to a custom format.</p>



<h3><span class="ez-toc-section" id="b_Where_are_logs_stored_on_a_Linux_filesystem">b &#8211; Where are logs stored on a Linux filesystem?</span></h3>



<p> Long story short, logs are stored at <strong>/var/log/</strong> on your filesystem.</p>



<p>At this location, you should see multiple log files, each one having a name describing what they actually store.</p>



<p>For a quick overview, you can execute the following command:</p>



<pre class="wp-block-code"><code>$ ls -l /var/log
-rw-r-----  1 syslog        adm               120999 Jul 24 18:04 auth.log
-rw-r--r--  1 root          root              127503 Jul 20 06:35 dpkg.log
-rw-r-----  1 syslog        adm                    0 Jul 15 06:25 kern.log
drwxrwxr-x  2 logstash      root                4096 Jul  8 18:33 logstash
drwxr-xr-x  2 root          root                4096 Sep 10  2018 lxd
drwxr-xr-x  2 mongodb       mongodb             4096 Jul  8 06:25 mongodb</code></pre>



<p>As you can see, you have dedicated log files for <strong>authentication purposes</strong> or for <strong>kernel related logs</strong>.</p>



<p>/var/log does not contain only files, but it also contain dedicated folders that vendors create when the application is installed.</p>



<p>As you can see, I am running a MongoDB database on my instance. </p>



<p>As a consequence, I have a MongoDB folder in my log folder.</p>



<blockquote class="wp-block-quote"><p>But why am I telling you all of this? </p></blockquote>



<p>Because using this knowledge, we are going to lay <strong>the first brick of your centralized logging architecture</strong>.</p>



<p>Suppose that three machines are sending logs to my server, each machine is going to have its own own auth.log, kern.log or dpkg.log files.</p>



<p>As a consequence, you want logs to be stored in dedicated folders, one for each instance.</p>



<p>Here&#8217;s <strong>the folder architecture</strong> on the server side.</p>



<figure class="wp-block-image alignwide"><img  alt="Centralized architecture folders"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture.png 1153w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-300x173.png 300w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-768x444.png 768w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-1024x591.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-585x338.png 585w" sizes="(max-width: 1153px) 100vw, 1153px" data-src="http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture.png" data-sizes="auto" class="wp-image-3050 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture.png" alt="Centralized architecture folders" class="wp-image-3050" srcset="http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture.png 1153w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-300x173.png 300w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-768x444.png 768w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-1024x591.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/centralized-folder-architecture-585x338.png 585w" sizes="(max-width: 1153px) 100vw, 1153px" /></noscript></figure>



<h2><span class="ez-toc-section" id="III_Designing_a_centralized_logging_architecture_on_Linux">III &#8211; Designing a centralized logging architecture on Linux</span></h2>



<p>Now that we have the basics of Linux logging, we are ready to <strong>design a centralized logging architecture</strong>. </p>



<p>As described in the first section, every machine in our pool is already writing logs via rsyslog. </p>



<p>However, natively, our machines are configured as <strong>client-server syslog instances</strong>. </p>



<p>They create logs, but they store them locally in the file system.</p>



<p>On our centralized logging architecture, client machines will be configured to use<strong> rsyslog as a client</strong>, and they will forward every single log to a <strong>remote rsyslog server</strong>, which is the central server.</p>



<figure class="wp-block-image alignwide"><img  alt="Complete schema for a centralized logging architecture"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1.png 1356w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-300x185.png 300w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-768x475.png 768w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-1024x633.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-1170x723.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-585x362.png 585w" sizes="(max-width: 1356px) 100vw, 1356px" data-src="http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1.png" data-sizes="auto" class="wp-image-3046 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1.png" alt="Complete schema for a centralized logging architecture" class="wp-image-3046" srcset="http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1.png 1356w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-300x185.png 300w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-768x475.png 768w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-1024x633.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-1170x723.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/logging-architecture-1-585x362.png 585w" sizes="(max-width: 1356px) 100vw, 1356px" /></noscript></figure>



<p>To be complete, our architecture has to:</p>



<ul><li><strong>Be secure</strong> : that&#8217;s why we are going to implement TLS in the fifth section;</li><li><strong>Be reliable</strong> : if the entire network goes down for a minute, are all logs for this period lost forever? Not with action queues.</li></ul>



<p>What are the advantages of such an architecture?</p>



<ul><li>You can<strong> inspect all your logs from a single place</strong> : you don&#8217;t rely on connecting individually to every machine on your pool, you can directly see the logs from the same filesystem.</li><li>You have access to logs, even if the host is not accessible : if one of the machines is having issues and it cannot be reached, you would not be able to go through the filesystem to look after logs. With a centralized logging server, you have the opportunity to look at logs, <strong>without any physical access to the client machine</strong>.</li><li>You can set up a complete log monitoring infrastructure : if you are interested in visualizing your logs with tools such as Kibana, <a href="http://devconnected.com/monitoring-linux-logs-with-kibana-and-rsyslog/">I wrote a complete guide about it</a>.</li></ul>



<p>On the other hand, what would be for us the drawbacks of such an architecture?</p>



<ul><li>You risk <strong>overloading your syslog server</strong> : with this architecture, you are pushing logs to a remote server. As a consequence, if one machine goes crazy and starts sending thousands of logs, you risk overloading the log server. (if you want a reliable back-pressure control, you can check <a data-abc="true" href="https://www.elastic.co/products/beats/filebeat">Filebeat</a> by Elastic)</li><li>If your log server goes down, <strong>you lose the ability to look at all the logs sent by the clients</strong>. Moreover, if the server goes down, clients will start storing messages locally until the server is available again, thus filling up disk space on the client side.</li></ul>



<h2><span class="ez-toc-section" id="IV_Configure_rsyslog_to_forward_logs_to_a_centralized_server">IV &#8211; Configure rsyslog to forward logs to a centralized server</span></h2>



<h3><span class="ez-toc-section" id="a_Prerequisites">a &#8211; Prerequisites</span></h3>



<p>First, make sure that you have <strong>rsyslog</strong> on your instance.</p>



<pre class="wp-block-code"><code>$ sudo systemctl status rsyslog</code></pre>



<div class="wp-block-image"><figure class="aligncenter is-resized"><img  alt="rsyslog service shell output"  width="579" height="248" data-srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-service.png 579w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-service-300x128.png 300w" sizes="(max-width: 579px) 100vw, 579px" data-src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-service.png" data-sizes="auto" class="wp-image-2977 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-service.png" alt="rsyslog service shell output" class="wp-image-2977" width="579" height="248" srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-service.png 579w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-service-300x128.png 300w" sizes="(max-width: 579px) 100vw, 579px" /></noscript></figure></div>



<p>If the service is unknown on your computer, you can install it by running:</p>



<pre class="wp-block-code"><code>$ sudo apt-get update &amp;&amp; apt-get install rsyslog
$ sudo systemctl enable rsyslog
$ sudo systemctl start rsyslog</code></pre>



<h3><span class="ez-toc-section" id="a_Configure_your_rsyslog_server">a &#8211; Configure your rsyslog server</span></h3>



<p>First of all, you have to configure your rsyslog server for it <strong>to accept incoming logs on port 514</strong>.</p>



<p> We are going to use <strong>TCP</strong> for log transmission, but you can use UDP if you don&#8217;t care that much about reliability.</p>



<p>On the server, head to <em>/etc/rsyslog.d</em> folder. </p>



<p>This is the directory that stores <strong>templates</strong> as well as files that contain the <strong>rsyslog rules</strong>.</p>



<p>In this directory, there should be a<strong> 50-default.conf</strong> file. </p>



<p>We are going to create our own configuration file, prefixing it with a number lower than the configuration file one. </p>



<p>This way, our configuration file takes priority over the default one. </p>



<pre class="wp-block-code"><code>$ sudo touch 01-server.conf

# Listen for TCP
$ModLoad imtcp
# Listen on port 514
$InputTCPServerRun 514

$template RemoteServer, "/var/log/%HOSTNAME%/%SYSLOGFACILITY-TEXT%.log"
*.* ?RemoteServer</code></pre>



<blockquote class="wp-block-quote"><p>Our first rule! </p></blockquote>



<figure class="wp-block-image alignwide"><img  alt="Details about rsyslog syntax"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax.png 1839w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-300x100.png 300w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-768x255.png 768w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-1024x340.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-1170x388.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-585x194.png 585w" sizes="(max-width: 1839px) 100vw, 1839px" data-src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax.png" data-sizes="auto" class="wp-image-3052 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax.png" alt="Details about rsyslog syntax" class="wp-image-3052" srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax.png 1839w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-300x100.png 300w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-768x255.png 768w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-1024x340.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-1170x388.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-syntax-585x194.png 585w" sizes="(max-width: 1839px) 100vw, 1839px" /></noscript></figure>



<p>With this syntax, our log files will be grouped by hostname (aka the computer name sending the log) and then by syslog facility (kern, user, auth etc..)</p>



<p>Restart your rsyslog server, and make sure that it is now listening on the port 514 for TCP</p>



<pre class="wp-block-code"><code>$ sudo systemctl restart rsyslog
$ netstat -tna | grep :514
tcp        0      0 0.0.0.0:514             0.0.0.0:*               LISTEN
tcp6       0      0 :::514                  :::*                    LISTEN</code></pre>



<blockquote class="wp-block-quote"><p><strong>Note</strong> : with this configuration file, your server logs are now longer directly stored in /var/log, but in /var/log/hostname, hostname being the current name of your host (in my case /var/log/schkn-ubuntu)</p></blockquote>



<pre class="wp-block-code"><code>$ uname -a
Linux schkn-ubuntu 4.15.0-42-generic #45-Ubuntu SMP Thu Nov 15 19:32:57 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux</code></pre>



<h3><span class="ez-toc-section" id="b_Configure_your_rsyslog_client">b &#8211; Configure your rsyslog client</span></h3>



<p>It is time to configure rsyslog as a client on our instance.</p>



<p>Now that we have rsyslog, head over to <em>/etc/rsyslog.d. </em></p>



<p>Similarly to the procedure done on the server-side create a <strong>01-client.conf</strong> file.</p>



<pre class="wp-block-code"><code>$ sudo vi 01-client.conf

*.*                         @@distant-server-ip:514</code></pre>



<p>The configuration on the client side is pretty simple, <strong>plain simple forwarding</strong>.</p>



<p>Restart your rsyslog server, and make sure that:</p>



<ul><li>You have no errors on the client-side</li></ul>



<pre class="wp-block-code"><code>$ sudo systemctl restart rsyslog
$ journalctl -f -u rsyslog</code></pre>



<ul><li>Your server now has the logs from the client</li></ul>



<p>My client machine is named &#8220;antoine-Virtualbox&#8221; in my current setup, so I am looking for <em>/var/log/antoine-Virtualbox.</em></p>



<div class="wp-block-image"><figure class="aligncenter"><img  alt="Folder architecture on the server"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/server-done.png 665w, http://devconnected.com/wp-content/uploads/2019/07/server-done-300x175.png 300w, http://devconnected.com/wp-content/uploads/2019/07/server-done-585x341.png 585w" sizes="(max-width: 665px) 100vw, 665px" data-src="http://devconnected.com/wp-content/uploads/2019/07/server-done.png" data-sizes="auto" class="wp-image-2988 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/server-done.png" alt="Folder architecture on the server" class="wp-image-2988" srcset="http://devconnected.com/wp-content/uploads/2019/07/server-done.png 665w, http://devconnected.com/wp-content/uploads/2019/07/server-done-300x175.png 300w, http://devconnected.com/wp-content/uploads/2019/07/server-done-585x341.png 585w" sizes="(max-width: 665px) 100vw, 665px" /></noscript></figure></div>



<p>Awesome! Distant logs are now correctly stored on our server.</p>



<p>However, I have some bad news for you. </p>



<p>As we are using TCP for log transmission, it means that <strong>messages are not encrypted</strong> between the client and the server.</p>



<p>As a consequence, any hacker that sniffs the packets on your network will be able to see your logs, spy on their content and perform attacks on your host machines.</p>



<p>This is what we call <strong>a man in the middle attack.</strong></p>



<p>As a proof, here&#8217;s a Wireshark instance sniffing my network and listening for a very specific IP.</p>



<figure class="wp-block-image alignwide"><img  alt="Unsecured TCP traffic from Wireshark"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/clear-message-2.png 1239w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-300x188.png 300w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-768x481.png 768w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-1024x641.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-1170x733.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-585x366.png 585w" sizes="(max-width: 1239px) 100vw, 1239px" data-src="http://devconnected.com/wp-content/uploads/2019/07/clear-message-2.png" data-sizes="auto" class="wp-image-2992 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/clear-message-2.png" alt="Unsecured TCP traffic from Wireshark" class="wp-image-2992" srcset="http://devconnected.com/wp-content/uploads/2019/07/clear-message-2.png 1239w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-300x188.png 300w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-768x481.png 768w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-1024x641.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-1170x733.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/clear-message-2-585x366.png 585w" sizes="(max-width: 1239px) 100vw, 1239px" /></noscript></figure>



<p>As you can see, the message is clearly visible and states : <em>&#8220;Hi, this is a test message&#8221;. </em></p>



<p>Now imagine if the log message contained sensitive information about your host, that could be a complete security disaster. </p>



<p>This is why we are going to <strong>setup TLS</strong>, allowing us to <strong>encrypt the traffic</strong> between the client and the server.</p>



<p>At the end of the next chapter, I will provide you with a Wireshark screenshot, proving that the traffic is now encrypted.</p>



<blockquote class="wp-block-quote"><p>Ready?</p></blockquote>



<h2><span class="ez-toc-section" id="V_Encrypting_rsyslog_messages_with_TLS"> V &#8211; Encrypting rsyslog messages with TLS</span></h2>



<p>In order for us to encrypt messages between the server and the client, we are going to use TLS and more precisely <strong>trusted certificates</strong>.</p>



<p>Without going into too many details, those trusted certificates will ensure that both client and server identities are verified. </p>



<p>With this protocol, the client and the server will first ensure that <strong>they are correctly talking to each other</strong> (as there is no one along the way with a fake identify), and then they will proceed to <strong>encrypt their messages</strong>.</p>



<p>As the client and the server exchanged their keys, they are able to decrypt messages on the fly.</p>



<p>In our setup, we will have <strong>a certificate authority signing the keys</strong>. </p>



<p>Communication between the hosts and the certificate authority is obviously encrypted too, so we need first to create a <strong>key-pair for the certificate authority</strong>.</p>



<figure class="wp-block-image alignwide"><img  alt="How TLS works for centralized architectures"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/tls-schema.png 1161w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-300x167.png 300w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-768x429.png 768w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-1024x572.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-585x327.png 585w" sizes="(max-width: 1161px) 100vw, 1161px" data-src="http://devconnected.com/wp-content/uploads/2019/07/tls-schema.png" data-sizes="auto" class="wp-image-3055 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/tls-schema.png" alt="How TLS works for centralized architectures" class="wp-image-3055" srcset="http://devconnected.com/wp-content/uploads/2019/07/tls-schema.png 1161w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-300x167.png 300w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-768x429.png 768w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-1024x572.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/tls-schema-585x327.png 585w" sizes="(max-width: 1161px) 100vw, 1161px" /></noscript></figure>



<p>If you are just testing out, you can use your rsyslog server as a certificate authority. </p>



<h3><span class="ez-toc-section" id="a_Configuring_your_certificate_authority">a &#8211; Configuring your certificate authority</span></h3>



<p>On the server, head over to /etc/ssl, and create a rsyslog directory.</p>



<pre class="wp-block-code"><code>$ sudo mkdir /etc/ssl/rsyslog
$ cd /etc/ssl/rsyslog</code></pre>



<p>Install the <strong>gnutls-utils</strong> package (that might come as the gnutls-bin for some distributions) that enables SSL API&#8217;s on your server.</p>



<pre class="wp-block-code"><code>$ sudo apt-get install gnutls-utils
(or)
$ sudo apt-get install gnutls-bin</code></pre>



<p>Generate a private key for the certificate authority:</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-privkey --outfile CA-key.pem
$ sudo chmod 400 CA-key.pem</code></pre>



<p>Generate a public key on the certificate authority:</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-self-signed --load-privkey CA-key.pem --outfile CA.pem
# Common name: authority.devconnected.com
  # The certificate will expire in (days): 3650
  # Does the certificate belong to an authority? (Y/N): y
  # Will the certificate be used to sign other certificates? (Y/N): y
  # Will the certificate be used to sign CRLs? (y/N): y</code></pre>



<p>You can leave the other questions blank as they will have no impacts on the final result.</p>



<h3><span class="ez-toc-section" id="b_Generating_privatepublic_keys_for_the_server">b &#8211; Generating private/public keys for the server</span></h3>



<p>Now that our certificate authority has keys to sign other keys, let&#8217;s create one for the rsyslog server.</p>



<p>First, create a private key for your server.</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-privkey --outfile server-key.pem --bits 2048</code></pre>



<p>Generate a certificate request for your server.</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-request --load-privkey server-key.pem --outfile server-request.pem</code></pre>



<p>Generate the certificate for your rsyslog server and import trusted certificate authority keys into it.</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-certificate --load-request server-request.pem --outfile server-cert.pem --load-ca-certificate CA.pem --load-ca-privkey CA-key.pem

  # The certificate will expire in (days): 3650
  # Is this a TLS web client certificate? (Y/N): y
  # Is this also a TLS web server certificate? (y/N): y
  # Enter a dnsName of the subject of the certificate: server.devconnected.com</code></pre>



<h3><span class="ez-toc-section" id="c_Generate_privatepublic_keys_for_the_client">c &#8211; Generate private/public keys for the client</span></h3>



<p>Similarly to what we have done before, let&#8217;s build our key pair for the client.</p>



<p>Create a private key for the client.</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-privkey --outfile client-key.pem --bits 2048</code></pre>



<p>Generate a certificate request for the client.</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-request --load-privkey client-key.pem --outfile client-request.pem</code></pre>



<p>Create a certificate (a public key) for your client and import the certificate authority certificates inside.</p>



<pre class="wp-block-code"><code>$ sudo certtool --generate-certificate --load-request client-request.pem --outfile client-cert.pem --load-ca-certificate CA.pem --load-ca-privkey CA-key.pem

# The certificate will expire in (days): 3650
  # Is this a TLS web client certificate? (Y/N): y
  # Is this also a TLS web server certificate? (y/N): y
  # Enter a dnsName of the subject of the certificate: client.devconnected.com</code></pre>



<p>Awesome! We now have key pairs for both our client and server.</p>



<h3><span class="ez-toc-section" id="d_Send_generated_keys_to_your_hosts">d &#8211; Send generated keys to your hosts</span></h3>



<p>Now that your keys are generated on the certificate authority, <strong>send your keys securely to the destination hosts</strong>.</p>



<p>For this, you can use scp.</p>



<p>For the server (simply switch to &#8216;client&#8217; when you want to send keys to the client)</p>



<pre class="wp-block-code"><code>$ sudo -u root scp -i ~/.ssh/id_rsa CA.pem server-* root@server_ip_here:/etc/ssl/rsyslog/</code></pre>



<h3><span class="ez-toc-section" id="e_Configure_your_rsyslog_server">e &#8211; Configure your rsyslog server</span></h3>



<p>Now that both servers and clients contain keys for encryption, let&#8217;s configure hosts to conclude this chapter.</p>



<p>First, install the <strong>gtls driver</strong> on your server.</p>



<pre class="wp-block-code"><code>$ sudo apt-get install rsyslog-gnutls</code></pre>



<p>As a reminder, we create a 01-server.conf file in the previous chapter. </p>



<p>Replace the content with the following configuration.</p>



<pre class="wp-block-code"><code># Listen for TCP
$ModLoad imtcp
# GTLS driver
$DefaultNetstreamDriver gtls
# Certificates
$DefaultNetstreamDriverCAFile /etc/ssl/rsyslog/CA.pem
$DefaultNetstreamDriverCertFile /etc/ssl/rsyslog/server-cert.pem
$DefaultNetstreamDriverKeyFile /etc/ssl/rsyslog/server-key.pem
# Authentication mode
$InputTCPServerStreamDriverAuthMode x509/name
$InputTCPServerStreamDriverPermittedPeer *.devconnected.com
# Only use TLS
$InputTCPServerStreamDriverMode 1
# Listen on port 514
$InputTCPServerRun 514

$template RemoteServer, "/var/log/%HOSTNAME%/%SYSLOGFACILITY-TEXT%.log"
*.* ?RemoteServer</code></pre>



<p>As you can see, we are adding a AuthMode, which is x509/name in this case. </p>



<p>This means that we are going to use a certificate that contains a &#8220;name&#8221; inside it.</p>



<blockquote class="wp-block-quote"><p>Remember when we declare that we were &#8220;client.devconnected.com&#8221; or &#8220;server.devconnected.com&#8221; when we created the certificates? </p></blockquote>



<p>This is exactly the information that the authentication is going to use, and you will get an error if the name does not match.</p>



<p>Don&#8217;t forget to restart rsyslog for the changes to be saved.</p>



<pre class="wp-block-code"><code>$ sudo systemctl restart rsyslog</code></pre>



<h3><span class="ez-toc-section" id="f_Configure_your_rsyslog_client">f &#8211; Configure your rsyslog client</span></h3>



<p>On the client, we had a simple forwarding rule in a 01-client.conf file.</p>



<p>Again, install the gtls driver on your client. </p>



<pre class="wp-block-code"><code>$ sudo apt-get install rsyslog-gnutls</code></pre>



<p>Replace the content with the following configuration.</p>



<pre class="wp-block-code"><code># GTLS driver
$DefaultNetstreamDriver gtls
# Certificates
$DefaultNetstreamDriverCAFile /etc/ssl/rsyslog/CA.pem
$DefaultNetstreamDriverCertFile /etc/ssl/rsyslog/client-cert.pem
$DefaultNetstreamDriverKeyFile /etc/ssl/rsyslog/client-key.pem
# Auth mode
$ActionSendStreamDriverAuthMode x509/name
$ActionSendStreamDriverPermittedPeer server.devconnected.com
# Only use TLS
$ActionSendStreamDriverMode 1
# Forward everything to server.devconnected.com
*.* @@distant-server-ip:514</code></pre>



<p>Restart your rsyslog client.</p>



<pre class="wp-block-code"><code>$ sudo systemctl restart rsyslog</code></pre>



<p>Awesome! Your logs should now be sent to your remote server. Run this command and make sure that you have no errors (if you do, I have a section for it at the end)</p>



<pre class="wp-block-code"><code>$ $ journalctl -u -n 100 rsyslog</code></pre>



<p>A promise is a promise, here&#8217;s my Wireshark between my server and my client, with a TLS encryption between them.</p>



<figure class="wp-block-image alignwide"><img  alt="Encrypted TCP traffic with TLS"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/encrypted-2.png 967w, http://devconnected.com/wp-content/uploads/2019/07/encrypted-2-300x251.png 300w, http://devconnected.com/wp-content/uploads/2019/07/encrypted-2-768x643.png 768w, http://devconnected.com/wp-content/uploads/2019/07/encrypted-2-585x489.png 585w" sizes="(max-width: 967px) 100vw, 967px" data-src="http://devconnected.com/wp-content/uploads/2019/07/encrypted-2.png" data-sizes="auto" class="wp-image-3010 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/encrypted-2.png" alt="Encrypted TCP traffic with TLS" class="wp-image-3010" srcset="http://devconnected.com/wp-content/uploads/2019/07/encrypted-2.png 967w, http://devconnected.com/wp-content/uploads/2019/07/encrypted-2-300x251.png 300w, http://devconnected.com/wp-content/uploads/2019/07/encrypted-2-768x643.png 768w, http://devconnected.com/wp-content/uploads/2019/07/encrypted-2-585x489.png 585w" sizes="(max-width: 967px) 100vw, 967px" /></noscript></figure>



<p>No way for you to decrypt the message.</p>



<blockquote class="wp-block-quote"><p><strong>Plot twist</strong> : I sent &#8220;Hi, this is a test message&#8221; again.</p></blockquote>



<h2><span class="ez-toc-section" id="VI_Sending_log_messages_reliably_with_action_queues">VI &#8211; Sending log messages reliably with action queues</span></h2>



<p>In the architecture that we designed before, there is one major issue that was not addressed before : <strong>reliability</strong>.</p>



<p>In our architecture, the client and the server are very tighly coupled. </p>



<blockquote class="wp-block-quote"><p>What does it mean? </p></blockquote>



<p style="text-align:left">If the server goes down, your client will obviously not be able to send log messages, but they might also risk losing the logs messages forever.</p>



<figure class="wp-block-image alignwide"><img  alt="rsyslog connection refused"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1.png 716w, http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1-300x9.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1-585x17.png 585w" sizes="(max-width: 716px) 100vw, 716px" data-src="http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1.png" data-sizes="auto" class="wp-image-3016 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1.png" alt="rsyslog connection refused" class="wp-image-3016" srcset="http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1.png 716w, http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1-300x9.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-losing-server-1-585x17.png 585w" sizes="(max-width: 716px) 100vw, 716px" /></noscript></figure>



<p>Luckily for us, rsyslog has a <strong>contingency plan</strong> when it comes to bad forwarding : plain and simple disabling the faulty module.</p>



<div class="wp-block-image"><figure class="aligncenter"><img  alt="rsyslog module suspended"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/module-disabled-1.png 442w, http://devconnected.com/wp-content/uploads/2019/07/module-disabled-1-300x14.png 300w" sizes="(max-width: 442px) 100vw, 442px" data-src="http://devconnected.com/wp-content/uploads/2019/07/module-disabled-1.png" data-sizes="auto" class="wp-image-3018 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/module-disabled-1.png" alt="rsyslog module suspended" class="wp-image-3018" srcset="http://devconnected.com/wp-content/uploads/2019/07/module-disabled-1.png 442w, http://devconnected.com/wp-content/uploads/2019/07/module-disabled-1-300x14.png 300w" sizes="(max-width: 442px) 100vw, 442px" /></noscript></figure></div>



<p>This means that you won&#8217;t lose your messages (they still be stored locally), but you are losing your log forwarding all together.</p>



<blockquote class="wp-block-quote"><p>Would you go back to your host to re-enable your forwarding module everytime the network goes down? I wouldn&#8217;t.</p></blockquote>



<p>To solve this, we need to bring decoupling in this architecture. </p>



<p><a data-abc="true" href="http://devconnected.com/the-10-best-software-engineering-books-in-2019/">If you read the Entreprise Integration Patterns book by Gregor Hohpe</a>, reliability means <strong>queues</strong>.</p>



<figure class="wp-block-image alignwide"><img  alt="Decoupling systems with queues"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2.png 1312w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-300x179.png 300w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-768x460.png 768w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-1024x613.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-1170x700.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-585x350.png 585w" sizes="(max-width: 1312px) 100vw, 1312px" data-src="http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2.png" data-sizes="auto" class="wp-image-3059 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2.png" alt="Decoupling systems with queues" class="wp-image-3059" srcset="http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2.png 1312w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-300x179.png 300w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-768x460.png 768w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-1024x613.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-1170x700.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/decoupled-arch-2-585x350.png 585w" sizes="(max-width: 1312px) 100vw, 1312px" /></noscript></figure>



<h3><span class="ez-toc-section" id="a_Designing_message_reliability">a &#8211; Designing message reliability</span></h3>



<p>First, let&#8217;s understand a couple of concepts related to rsyslog message queues.</p>



<div class="wp-block-image"><figure class="aligncenter"><img  alt="rsyslog architecture"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues.png 660w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues-300x164.png 300w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues-585x319.png 585w" sizes="(max-width: 660px) 100vw, 660px" data-src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues.png" data-sizes="auto" class="wp-image-3057 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues.png" alt="rsyslog architecture" class="wp-image-3057" srcset="http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues.png 660w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues-300x164.png 300w, http://devconnected.com/wp-content/uploads/2019/07/rsyslog-queues-585x319.png 585w" sizes="(max-width: 660px) 100vw, 660px" /></noscript></figure></div>



<p>In rsyslog, there are multiple ways for you to design queues, but eventually it comes up the three main categories:</p>



<ul><li><strong>Direct</strong> : this is kind of a &#8220;no queue&#8221; mode where messages are directly passed from the producer to the consumer. Definitely not a mode we want implemented in our case;</li><li><strong>Disk queues</strong>: in this case, as messages are passed to the queue, they are reliably written to disk. In this case, you are safer when it comes to machine complete accidental shutdown, but the process is longer than memory queues. Writing to disk is more expensive that writing in the RAM;</li><li><strong>Memory queues</strong>:  those queues will hold messages in memory for a given time and for a given amount of restricted space. After a while, they will be written to disk. This alternative is faster than disk queues.</li></ul>



<p>For our architecture, we are going to use <strong>memory queues</strong> with a bunch of different options (<a href="https://www.rsyslog.com/doc/master/rainerscript/queue_parameters.html">all options are available here</a>)</p>



<p>In your <strong>01-client.conf file</strong>, append the following lines to your the configuration file.</p>



<pre class="wp-block-code"><code>$ActionQueueType LinkedList
$ActionQueueFileName rsyslog_backup
$ActionQueueSaveOnShutdown on
$ActionResumeRetryCount -1
...
# Parameters from the TLS section
$ActionSendStreamDriverAuthMode x509/name</code></pre>



<ul><li><strong>LinkedList</strong>: we want memory allocation to be done on the fly, and not via a fixed array. This will create more <strong>overhead computation</strong> but you will benefit from it by gaining <strong>more space</strong>;</li><li><strong>Queue file name</strong>: this is the file where data is going to be written if data is eventually stored to disk. The path to it is $WorkDirectory/rsyslog_backup where WorkDirectory is the variable defined in your rsyslog.conf file;</li><li><strong>Save on shutdown</strong>: if the machine was to shutdown, the memory logs would be written to disk first;</li><li><strong>Resume retry count</strong>: when losing the forwarding module, rsyslog will try to reconnect to it indefinitely.</li></ul>



<p>You can tweak it more given the specifications you are working with, but I will go with that for this tutorial.</p>



<p>Restart rsyslog, and make sure that you are not having any errors.</p>



<pre class="wp-block-code"><code>$ sudo systemctl restart rsyslog
$ sudo journalctl -f -u rsyslog.service</code></pre>



<h3><span class="ez-toc-section" id="b_Demonstrating_message_reliability">b &#8211; Demonstrating message reliability</span></h3>



<p>Okay, now that we have message reliability put in place, let&#8217;s test it out.</p>



<p>On the server side, comment all the lines in your 01-server.conf file and restart rsyslog. From this point, <strong>your client should lose its connection to the server.</strong></p>



<p>On the client:</p>



<pre class="wp-block-code"><code>$ sudo journalctl -f -u rsyslog.service</code></pre>



<figure class="wp-block-image alignwide"><img  alt="rsyslog more connection refused"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection.png 1284w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-300x14.png 300w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-768x37.png 768w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-1024x49.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-1170x56.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-585x28.png 585w" sizes="(max-width: 1284px) 100vw, 1284px" data-src="http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection.png" data-sizes="auto" class="wp-image-3026 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection.png" alt="rsyslog more connection refused" class="wp-image-3026" srcset="http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection.png 1284w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-300x14.png 300w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-768x37.png 768w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-1024x49.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-1170x56.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/client-losing-connection-585x28.png 585w" sizes="(max-width: 1284px) 100vw, 1284px" /></noscript></figure>



<p>On the client, manually fire a log event.</p>



<pre class="wp-block-code"><code>$ logger -p 'auth.crit' 'Critial auth message, lost?'</code></pre>



<p>Verify that you are not receiving anything at all on the server, and that the client does not fire any preemptive message.</p>



<p>From there, <strong>your message is stored in memory</strong>, patiently waiting for the module to be back up.</p>



<p>Go to the server side, remove comments for all the lines, and restart your rsyslog server.</p>



<p>From there, <strong>your client will automatically re-enable the forwarding module.</strong></p>



<figure class="wp-block-image alignwide"><img  alt="rsyslog module resumed"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up.png 676w, http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up-300x8.png 300w, http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up-585x16.png 585w, http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up-640x19.png 640w" sizes="(max-width: 676px) 100vw, 676px" data-src="http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up.png" data-sizes="auto" class="wp-image-3027 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up.png" alt="rsyslog module resumed" class="wp-image-3027" srcset="http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up.png 676w, http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up-300x8.png 300w, http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up-585x16.png 585w, http://devconnected.com/wp-content/uploads/2019/07/client-module-back-up-640x19.png 640w" sizes="(max-width: 676px) 100vw, 676px" /></noscript></figure>



<p>But, did our server receive the message that was stored in the client memory? It did!</p>



<figure class="wp-block-image alignwide"><img  alt="Checking auth log files on the server"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/server-received-message.png 778w, http://devconnected.com/wp-content/uploads/2019/07/server-received-message-300x31.png 300w, http://devconnected.com/wp-content/uploads/2019/07/server-received-message-768x80.png 768w, http://devconnected.com/wp-content/uploads/2019/07/server-received-message-585x61.png 585w" sizes="(max-width: 778px) 100vw, 778px" data-src="http://devconnected.com/wp-content/uploads/2019/07/server-received-message.png" data-sizes="auto" class="wp-image-3028 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/server-received-message.png" alt="Checking auth log files on the server" class="wp-image-3028" srcset="http://devconnected.com/wp-content/uploads/2019/07/server-received-message.png 778w, http://devconnected.com/wp-content/uploads/2019/07/server-received-message-300x31.png 300w, http://devconnected.com/wp-content/uploads/2019/07/server-received-message-768x80.png 768w, http://devconnected.com/wp-content/uploads/2019/07/server-received-message-585x61.png 585w" sizes="(max-width: 778px) 100vw, 778px" /></noscript></figure>



<p>Congratulations, you designed (secure!) message reliability between rsyslog clients and a rsyslog server.</p>



<h2><span class="ez-toc-section" id="Common_Errors">Common Errors</span></h2>



<p>Here is a list of the different errors that you may encounter during the process:</p>



<ul><li><strong>omfwd: TCPSendBuf error -2027, destruct TCP connection the x.x.x.x</strong></li></ul>



<figure class="wp-block-image alignwide"><img  alt="error tcp connection destructed"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1.png 853w, http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1-300x12.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1-768x30.png 768w, http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1-585x23.png 585w" sizes="(max-width: 853px) 100vw, 853px" data-src="http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1.png" data-sizes="auto" class="wp-image-3034 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1.png" alt="error tcp connection destructed" class="wp-image-3034" srcset="http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1.png 853w, http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1-300x12.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1-768x30.png 768w, http://devconnected.com/wp-content/uploads/2019/07/error-1-ssl-1-585x23.png 585w" sizes="(max-width: 853px) 100vw, 853px" /></noscript></figure>



<p><strong>Solution</strong>: if you are having this error in the TLS section, your TLS configuration is probably wrong. Either you have badly configured the certificates, or you have a wrong server configuration.</p>



<ul><li><strong>Cannot connect to x.x.x.x : network is unreachable.</strong></li></ul>



<figure class="wp-block-image alignwide"><img  alt="rsyslog error, network unreachable"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable.png 743w, http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable-300x13.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable-585x26.png 585w" sizes="(max-width: 743px) 100vw, 743px" data-src="http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable.png" data-sizes="auto" class="wp-image-3036 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable.png" alt="rsyslog error, network unreachable" class="wp-image-3036" srcset="http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable.png 743w, http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable-300x13.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-2-network-unreachable-585x26.png 585w" sizes="(max-width: 743px) 100vw, 743px" /></noscript></figure>



<p><strong>Solution </strong>: make sure that the IP address can be accessed from the client host. You can ping it by example.</p>



<pre class="wp-block-code"><code>$ ping 142.93.103.142
PING 142.93.103.142 (142.93.103.142) 56(84) bytes of data.
64 bytes from 142.93.103.142: icmp_seq=1 ttl=64 time=0.023 ms
64 bytes from 142.93.103.142: icmp_seq=2 ttl=64 time=0.056 ms
64 bytes from 142.93.103.142: icmp_seq=3 ttl=64 time=0.033 ms
--- 142.93.103.142 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2047ms</code></pre>



<ul><li><strong>Peer name not authorized : not permitted to talk to it. Names CN: name.domain.com</strong></li></ul>



<figure class="wp-block-image alignwide"><img  alt="rsyslog error, peer name not permitted"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host.png 1025w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-300x9.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-768x23.png 768w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-1024x31.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-585x18.png 585w" sizes="(max-width: 1025px) 100vw, 1025px" data-src="http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host.png" data-sizes="auto" class="wp-image-3038 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host.png" alt="rsyslog error, peer name not permitted" class="wp-image-3038" srcset="http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host.png 1025w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-300x9.png 300w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-768x23.png 768w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-1024x31.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/error-3-not-correct-host-585x18.png 585w" sizes="(max-width: 1025px) 100vw, 1025px" /></noscript></figure>



<p>In the rsyslog configuration file, make sure that you have the  $ActionSendStreamDriverPermittedPeers correctly set.</p>



<h2><span class="ez-toc-section" id="Bonus_A_word_on_back-pressure_protocols">Bonus : A word on back-pressure protocols</span></h2>



<p>Before ending this guide, there is one point that I want to address, as I think that it might be something that could be improved in this architecture.</p>



<h3><span class="ez-toc-section" id="a_Architectural_improvements">a &#8211; Architectural improvements</span></h3>



<p>The architecture that we designed together can be seen as a &#8220;<strong>push</strong>&#8221; architecture. We essentially push logs from the client to the servers. </p>



<p>And that&#8217;s risky.</p>



<blockquote class="wp-block-quote"><p>Why?</p></blockquote>



<p>Because if the clients begin to send too many logs files to your server, <strong>you have the risks of overloading your entire system</strong>, preventing other clients to send data. From there, it is only a matter of time until your server goes down, or until you start losing logs files completely.</p>



<p>Here are some thoughts about how to handle this:</p>



<ul><li>Use the <strong>dequeueSlowDown</strong> rsyslog parameter to delay message execution, essentially putting a tempo on all the messages being sent. <a data-abc="true" href="https://www.rsyslog.com/doc/v8-stable/rainerscript/queue_parameters.html#queue-dequeueslowdown">Here is a link to it.</a></li><li>Use a <strong>back-pressure third-party product</strong> like Filebeat. Filebeat can be interesting if you are already working with the ELK stack all together. It implements native back-pressure protocol for you to set a rate on when the logs are being sent. </li></ul>



<h3><span class="ez-toc-section" id="b_Push_vs_Pull_logging_systems">b &#8211; Push vs Pull logging systems</span></h3>



<p>We have already tackled <a href="http://devconnected.com/the-definitive-guide-to-prometheus-in-2019/#b_Pull_vs_Push">the difference between push and pull systems at least when it comes to open source monitoring solutions. </a></p>



<blockquote class="wp-block-quote"><p>We have seen the advantage of building an active monitoring solution, but couldn&#8217;t we apply the same principles when it comes to centralized logging systems?</p></blockquote>



<p>As our log files are stored to disks, there is definitely a way for us to parse those files regularly and extract logs, at a rate that we decide on the server side. This point removes the danger from having a client overloading our servers.</p>



<figure class="wp-block-image alignwide"><img  alt="Push vs pull centralized architecture"  data-srcset="http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull.png 1329w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-300x230.png 300w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-768x590.png 768w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-1024x787.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-1170x899.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-585x449.png 585w" sizes="(max-width: 1329px) 100vw, 1329px" data-src="http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull.png" data-sizes="auto" class="wp-image-3061 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull.png" alt="Push vs pull centralized architecture" class="wp-image-3061" srcset="http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull.png 1329w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-300x230.png 300w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-768x590.png 768w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-1024x787.png 1024w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-1170x899.png 1170w, http://devconnected.com/wp-content/uploads/2019/07/push-vs-pull-585x449.png 585w" sizes="(max-width: 1329px) 100vw, 1329px" /></noscript></figure>



<blockquote class="wp-block-quote"><p>Are you aware of a system that is designed this way?</p></blockquote>



<h2><span class="ez-toc-section" id="Conclusion">Conclusion</span></h2>



<p>This last point ends this definitive guide about centralized logging for Linux systems.</p>



<p>In this guide, we went through pretty much <strong>all the aspects of centralized logging</strong>: from one single instance, to log forwarding to a central server in a secure and reliable way.</p>



<p>If you really want to go further on the subject, here are some videos that are related to the subjects, and that I found interesting.</p>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-4-3 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Rsyslog message flow (video Tutorial)" width="1170" height="878" src="https://www.youtube.com/embed/Re7AS__MkXw?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>



<p>I hope that you learned something today.</p>



<p>Don&#8217;t hesitate to check my other articles about monitoring or system administration, they are all equally detailed and insightful.</p>



<p>Until then, have fun, as always.</p>
			
			<div class="penci-single-link-pages">
						</div>
			
												<div class="post-tags">
						<a href="http://devconnected.com/tag/architecture/" rel="tag">architecture</a><a href="http://devconnected.com/tag/centralized-architecture/" rel="tag">centralized architecture</a><a href="http://devconnected.com/tag/logging/" rel="tag">logging</a><a href="http://devconnected.com/tag/rsyslog/" rel="tag">rsyslog</a><a href="http://devconnected.com/tag/syslog/" rel="tag">syslog</a><a href="http://devconnected.com/tag/system-administration/" rel="tag">system administration</a>					</div>
									</div>
	</div>

	
			<div class="tags-share-box center-box">

							<span class="single-comment-o"><i class="fa fa-comment-o"></i>0 comment</span>
			
							<div class="post-share">
					<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="2959" title="Like" data-like="Like" data-unlike="Unlike"><i class="fa fa-heart-o"></i></a>					<div class="list-posts-share"><a target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/"><i class="fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20The%20Definitive%20Guide%20to%20Centralized%20Logging%20with%20Syslog%20on%20Linux%20-%20http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/"><i class="fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a target="_blank" rel="nofollow" href="https://reddit.com/submit?url=http%3A%2F%2Fdevconnected.com%2Fthe-definitive-guide-to-centralized-logging-with-syslog-on-linux%2F&#038;title=The%20Definitive%20Guide%20to%20Centralized%20Logging%20with%20Syslog%20on%20Linux"><i class="fa fa-reddit"></i><span class="dt-share">Reddit</span></a></div>				</div>
					</div>
	
			<div class="post-author">
	<div class="author-img">
		<img alt=''  data-srcset='http://0.gravatar.com/avatar/96c5601ef18e54ecc99dbb77e5da7d69?s=200&#038;d=mm&#038;r=g 2x'  height='100' width='100' data-src="http://0.gravatar.com/avatar/96c5601ef18e54ecc99dbb77e5da7d69?s=100&#038;d=mm&#038;r=g" data-sizes="auto" class="avatar avatar-100 photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img alt='' src='http://0.gravatar.com/avatar/96c5601ef18e54ecc99dbb77e5da7d69?s=100&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/96c5601ef18e54ecc99dbb77e5da7d69?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /></noscript>	</div>
	<div class="author-content">
		<h5><a href="http://devconnected.com/author/schkn/" title="Posts by schkn" rel="author">schkn</a></h5>
		<p></p>
																	</div>
</div>		
	<div class="penci-flag-rlt-popup"></div>
			<div class="post-pagination">
				<div class="prev-post">
						<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="http://devconnected.com/how-to-install-logstash-on-ubuntu-18-04-and-debian-9/">
					<div class="pagi-text">
						<h5 class="prev-title">How To Install Logstash on Ubuntu 18.04 and Debian 9</h5>
					</div>
				</a>
			</div>
		</div>
	
	</div>	
					<div class="post-related penci-posts-related-grid">
		<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
				<div class="penci-related-carousel penci-related-grid-display">
								<div class="item-related">
																		<a class="related-thumb penci-image-holder penci-lazy" data-src="http://devconnected.com/wp-content/uploads/2019/07/final-dashboard-1-585x390.png" href="http://devconnected.com/monitoring-linux-logs-with-kibana-and-rsyslog/" title="Monitoring Linux Logs with Kibana and Rsyslog">
																			</a>
										<h3><a href="http://devconnected.com/monitoring-linux-logs-with-kibana-and-rsyslog/">Monitoring Linux Logs with Kibana and Rsyslog</a></h3>
										<span class="date"><time class="entry-date published" datetime="2019-07-16T18:06:41+00:00">July 16, 2019</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder penci-lazy" data-src="http://devconnected.com/wp-content/uploads/2019/07/featured.png" href="http://devconnected.com/how-to-install-influxdb-on-ubuntu-debian-in-2019/" title="How To Install InfluxDB 1.7 and 2.0 on Linux in 2019">
																			</a>
										<h3><a href="http://devconnected.com/how-to-install-influxdb-on-ubuntu-debian-in-2019/">How To Install InfluxDB 1.7 and 2.0 on...</a></h3>
										<span class="date"><time class="entry-date published" datetime="2019-07-06T10:08:21+00:00">July 6, 2019</time></span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder penci-lazy" data-src="http://devconnected.com/wp-content/uploads/2019/06/featured-image-1.png" href="http://devconnected.com/how-to-install-grafana-on-ubuntu-18-04/" title="How To Install Grafana on Ubuntu 18.04">
																			</a>
										<h3><a href="http://devconnected.com/how-to-install-grafana-on-ubuntu-18-04/">How To Install Grafana on Ubuntu 18.04</a></h3>
										<span class="date"><time class="entry-date published" datetime="2019-06-30T17:58:19+00:00">June 30, 2019</time></span>
									</div>
		</div></div>		
	<div class="penci-flag-rlt-popup"></div>	
			<div class="post-comments no-comment-yet" id="comments">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="http://devconnected.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='2959' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	</div> <!-- end comments div -->
		
	<div class="penci-flag-rlt-popup"></div>
</article>					</div>
	</div>
			
<div id="sidebar" class="penci-sidebar-content style-7 pcalign-left penci-sticky-sidebar">
	<div class="theiaStickySidebar">
		<aside id="penci_about_widget-1" class="widget penci_about_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">About Me</span></h4>
			<div class="about-widget pc_alignleft">
																				<img class="penci-widget-about-image nopin holder-square penci-lazy" nopin="nopin" src="http://devconnected.com/wp-content/themes/soledad/images/penci2-holder.png" data-src="https://i.imgur.com/sCZoV49.jpg" alt="About Me"/>
														
									<h2 class="about-me-heading">Software Engineer</h2>
				
									<p>I am Antoine Solnichkin, software engineer and writer based in Luxembourg. 
On devconnected, you'll find quality engineering articles for trending technologies.</p>
				
			</div>

			</aside><aside id="mc4wp_form_widget-4" class="widget widget_mc4wp_form_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Newsletter</span></h4><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.5.3 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-1749" method="post" data-id="1749" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p class="mdes">Subscribe to our newsletter for new blog posts about software engineering. Let's stay updated!</p>
				<p class="mname"><input type="text" name="NAME" placeholder="Name..." /></p>
				<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
				<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1564348431" /><input type="hidden" name="_mc4wp_form_id" value="1749" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></aside><aside id="media_image-5" class="widget widget_media_image"><img width="300" height="169"   alt="" style="max-width: 100%; height: auto;" data-srcset="http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-300x169.png 300w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-768x432.png 768w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-1024x576.png 1024w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-1170x663.png 1170w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-585x329.png 585w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_.png 1280w" sizes="(max-width: 300px) 100vw, 300px" data-src="http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-300x169.png" data-sizes="auto" class="image wp-image-2172  attachment-medium size-medium lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="300" height="169" src="http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-300x169.png" class="image wp-image-2172  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-300x169.png 300w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-768x432.png 768w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-1024x576.png 1024w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-1170x663.png 1170w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_-585x329.png 585w, http://devconnected.com/wp-content/uploads/2019/05/Need-a-write-up-guide-or-tutorial_.png 1280w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></aside><aside id="recent-comments-2" class="widget widget_recent_comments"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Comments</span></h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/' rel='external nofollow' class='url'>The Definitive Guide to Centralized Logging with Syslog on Linux</a></span> on <a href="http://devconnected.com/the-definitive-guide-to-prometheus-in-2019/#comment-889">The Definitive Guide To Prometheus in 2019</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://devconnected.com/the-definitive-guide-to-centralized-logging-with-syslog-on-linux/' rel='external nofollow' class='url'>The Definitive Guide to Centralized Logging with Syslog on Linux</a></span> on <a href="http://devconnected.com/the-10-best-software-engineering-books-in-2019/#comment-888">The 10 Best Software Engineering Books in 2019</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://devconnected.com/mongodb-monitoring-with-grafana-prometheus/' rel='external nofollow' class='url'>MongoDB Monitoring with Grafana &amp; Prometheus &ndash; devconnected</a></span> on <a href="http://devconnected.com/complete-mysql-dashboard-with-grafana-prometheus/#comment-887">Complete MySQL dashboard with Grafana &#038; Prometheus</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://devconnected.com/how-to-install-grafana-on-ubuntu-18-04/' rel='external nofollow' class='url'>How To Install Grafana on Ubuntu 18.04 &ndash; devconnected</a></span> on <a href="http://devconnected.com/geolocating-ssh-hackers-in-real-time/#comment-886">Geolocating SSH Hackers In Real-Time</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://devconnected.com/how-to-install-influxdb-on-ubuntu-debian-in-2019/' rel='external nofollow' class='url'>How To Install InfluxDB 1.7 and 2.0 on Linux in 2019 &ndash; devconnected</a></span> on <a href="http://devconnected.com/monitoring-systemd-services-in-realtime-with-chronograf/#comment-885">Monitoring systemd services in realtime with Chronograf</a></li></ul></aside><aside id="archives-2" class="widget widget_archive"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Archives</span></h4>		<ul>
				<li><a href='http://devconnected.com/2019/07/'>July 2019</a></li>
	<li><a href='http://devconnected.com/2019/06/'>June 2019</a></li>
	<li><a href='http://devconnected.com/2019/05/'>May 2019</a></li>
	<li><a href='http://devconnected.com/2019/04/'>April 2019</a></li>
		</ul>
			</aside><aside id="penci_social_widget-1" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
			<div class="widget-social pc_aligncenter show-text remove-border-radius penci-social-colored">
				
									<a href="https://twitter.com/devconnectedcom" rel="nofollow" target="_blank"><i class="fa fa-twitter" style="font-size: 14px"></i><span style="font-size: 13px">Twitter</span></a>
				
				
				
				
									<a href="https://www.linkedin.com/in/antoine-solnichkin-2ba22a54/" rel="nofollow" target="_blank"><i class="fa fa-linkedin" style="font-size: 14px"></i><span style="font-size: 13px">Linkedin</span></a>
				
				
				
				
				
				
				
				
				
				
				
				
									<a href="http://www.github.com/SCHKN" rel="nofollow" target="_blank"><i class="fa fa-github" style="font-size: 14px"></i><span style="font-size: 13px">Github</span></a>
				
				
				
				
				
				
				
				
				
				
								
				
								
				
							</div>

			</aside>	</div>
</div>	
<!-- END CONTAINER -->
</div>

<div class="clear-footer"></div>




	<div class="footer-subscribe">
		<aside id="mc4wp_form_widget-1" class="widget widget_mc4wp_form_widget"><h4 class="footer-subscribe-title">Subscribe Newsletter</h4><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.5.3 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-1749" method="post" data-id="1749" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><p class="mdes">Subscribe to our newsletter for new blog posts about software engineering. Let's stay updated!</p>
				<p class="mname"><input type="text" name="NAME" placeholder="Name..." /></p>
				<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
				<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1564348431" /><input type="hidden" name="_mc4wp_form_id" value="1749" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></aside>	</div>

<footer id="footer-section" class="penci-footer-social-media penci-lazy footer-social-remove-circle" itemscope itemtype="https://schema.org/WPFooter">
	<div class="container">
					<div class="footer-socials-section penci-social-textcolored">
				<ul class="footer-socials">
																<li><a href="https://twitter.com/devconnectedcom" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i><span>Twitter</span></a></li>
																															<li><a href="https://www.linkedin.com/in/antoine-solnichkin-2ba22a54/" rel="nofollow" target="_blank"><i class="fa fa-linkedin"></i><span>Linkedin</span></a></li>
																																				<li><a href="mailto:solnichkin.antoine@gmail.com"><i class="fa fa-envelope-o"></i><span>Email</span></a></li>
																																														<li><a href="http://www.github.com/SCHKN" rel="nofollow" target="_blank"><i class="fa fa-github"></i><span>Github</span></a></li>
																																																																															</ul>
			</div>
				<div class="penci-flag-rlt-popup"></div>					<div class="footer-logo-copyright footer-not-logo footer-not-gotop">
				
				
									<div id="footer-copyright">
						<p>Copyright © 2019 Antoine Solnichkin for devconnected. All rights reserved</p>
					</div>
											</div>
							<div class="penci-go-to-top-floating"><i class="fa fa-angle-up"></i></div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->
		<aside class="penci-rlt-popup penci-rltpopup-left">
		<h3 class="rtlpopup-heading">Read also<a class="penci-close-rltpopup">x<span></span><span></span></a></h3>
		
		<div class="penci-rtlpopup-content">
						<div class="rltpopup-item" style="transition-delay: 400ms; -webkit-transition-delay: 400ms;">
					<div class="rltpopup-item-inner">
																					<figure class="rltpopup-thumbnail">
									<a class="rltpopup-thumb penci-image-holder penci-lazy" data-src="http://devconnected.com/wp-content/uploads/2019/04/dashboard-263x175.png" href="http://devconnected.com/monitoring-systemd-services-in-realtime-with-chronograf/" title="Monitoring systemd services in realtime with Chronograf"></a>
								</figure>
																			<div class="rltpopup-meta">
							<h4><a class="rltpopup-title" href="http://devconnected.com/monitoring-systemd-services-in-realtime-with-chronograf/">Monitoring systemd services in realtime with Chronograf</a></h4>
														<span class="date"><time class="entry-date published" datetime="2019-04-11T17:45:13+00:00">April 11, 2019</time></span>
													</div>
					</div>
				</div>
						<div class="rltpopup-item" style="transition-delay: 480ms; -webkit-transition-delay: 480ms;">
					<div class="rltpopup-item-inner">
																					<figure class="rltpopup-thumbnail">
									<a class="rltpopup-thumb penci-image-holder penci-lazy" data-src="http://devconnected.com/wp-content/uploads/2019/06/final-dashboard-1-263x175.png" href="http://devconnected.com/monitoring-disk-i-o-on-linux-with-the-node-exporter/" title="Monitoring Disk I/O on Linux with the Node Exporter"></a>
								</figure>
																			<div class="rltpopup-meta">
							<h4><a class="rltpopup-title" href="http://devconnected.com/monitoring-disk-i-o-on-linux-with-the-node-exporter/">Monitoring Disk I/O on Linux with the Node...</a></h4>
														<span class="date"><time class="entry-date published" datetime="2019-06-03T18:15:21+00:00">June 3, 2019</time></span>
													</div>
					</div>
				</div>
						<div class="rltpopup-item" style="transition-delay: 560ms; -webkit-transition-delay: 560ms;">
					<div class="rltpopup-item-inner">
																					<figure class="rltpopup-thumbnail">
									<a class="rltpopup-thumb penci-image-holder penci-lazy" data-src="http://devconnected.com/wp-content/uploads/2019/06/featured-1-263x175.png" href="http://devconnected.com/complete-node-exporter-mastery-with-prometheus/" title="Complete Node Exporter Mastery with Prometheus"></a>
								</figure>
																			<div class="rltpopup-meta">
							<h4><a class="rltpopup-title" href="http://devconnected.com/complete-node-exporter-mastery-with-prometheus/">Complete Node Exporter Mastery with Prometheus</a></h4>
														<span class="date"><time class="entry-date published" datetime="2019-06-22T16:12:04+00:00">June 22, 2019</time></span>
													</div>
					</div>
				</div>
		</div></aside>
<div id="fb-root"></div>
<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/devconnected.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/852fd666437e8ac882a90f99d93b222d.js'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/penci-recipe/js/jquery.rateyo.min.js?ver=2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"http:\/\/devconnected.com\/wp-admin\/admin-ajax.php","nonce":"9c8b480768"};
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/9bd2601221c2acd2852802f3eb07da82.js'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/penci-review/js/jquery.easypiechart.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/ebbea783bea56dfd6c3a091788e4be8c.js'></script>
<script type='text/javascript'>
window.lazySizesConfig = window.lazySizesConfig || {};

window.lazySizesConfig.lazyClass    = 'lazyload';
window.lazySizesConfig.loadingClass = 'lazyloading';
window.lazySizesConfig.loadedClass  = 'lazyloaded';

//page is optimized for fast onload event
lazySizesConfig.loadMode = 1;
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.2.2.1'></script>
<script type='text/javascript'>
lazySizes.init();
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/themes/soledad/js/libs-script.min.js?ver=6.3.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"http:\/\/devconnected.com\/wp-admin\/admin-ajax.php","nonce":"9c8b480768"};
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/accf21ccf6735a58ea1838c7eff111c4.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"http:\/\/devconnected.com\/wp-admin\/admin-ajax.php","nonce":"9c8b480768"};
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/uploads/hummingbird-assets/08ea135cd9e73a1cea35f613382a4f7c.js'></script>
<script type='text/javascript' src='http://devconnected.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/easy-table-of-contents/vendor/smooth-scroll/jquery.smooth-scroll.min.js?ver=1.5.5'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/easy-table-of-contents/vendor/js-cookie/js.cookie.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/easy-table-of-contents/vendor/sticky-kit/jquery.sticky-kit.min.js?ver=1.9.2'></script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/easy-table-of-contents/vendor/waypoints/jquery.waypoints.min.js?ver=1.9.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"auto","scroll_offset":"30"};
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/easy-table-of-contents/assets/js/front.min.js?ver=1.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.5.3'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://devconnected.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.5.3'></script>
<![endif]-->


</body>
</html>